Featured models

Browse by date
β J F M A M J J A S O N D
1999                        
2000                        
2001                        
2002                        
2003                        
2004                        
2005                        
2006                        
2007                        
2008                        
2009                        
2010                        
2011                        
2012                        
2013                        
2014                        
2015                        
2016                        
2017      

Chat Page News
Sunday 26th March 2017

Please bookmark http://chat.palsite.com/chat_page.py as the new URL.

previous new post   refresh  next
Boby
Wednesday 2nd April 2003
6:48 am U.K.

bobymc@hotmail.com

Hi....... i got a "dead Video switcher" anybody can help?, it wont detect signal presence,its digital.

thank you very muchRegards

Olive Thomas
Wednesday 2nd April 2003
2:41 am U.K.

olive_e_thomas@yah¿¿.n¿spam.c¿m

_@_v - Sounds like that SL-HFR 70 need to be sent to the Olive E Thomas Memorial Home for Wayward Betamaxes for 'discipline'....

Franny Wentzel
Wednesday 2nd April 2003
2:16 am U.K.

franny_wentzel@yahoo.idontlikespam.co.uk

_@_¼¼ - check the back of your beta for a 50hz/60hz switch. USA takes the 60 hz setting

Brenda Ann
Wednesday 2nd April 2003
1:03 am U.K.

brendad@shinbiro.com

That is definately a strange one... since clocks on VCR's generally work from pulses off the AC line (this is why clocks in PAL/SECAM only VCR's will generally run very fast when used in NTSC countries... (50Hz vs. 60Hz line frequencies). VCR's made for multiple systems use a crystal and divider IC to run their clocks. If a clock starts running only a little slow, perhaps it is simply not getting all the pulses through.. if fast, perhaps the pulses are distorted and the clock is seeing more than one pulse during the period...

Sean Meskill
Wednesday 2nd April 2003
12:43 am U.K.

smeskill@attbi.comebackformore

A friend of mine was once driven near insane in a day by a clock that had been correct for some odd 30 years and had all of a a sudden started running a 37-second minute. I don't know what would cause a fast clock, it's certainly an odd problem. Try un-plugging the machine long enough to clear it all and then reset the clock. That's all I can think of. I don't know if there's an adjustment for it.

Jesse
Wednesday 2nd April 2003
12:36 am U.K.

newspaperman5000@hotmail.spamstop.com

Has anyone ever encountered a "fast" clock on a Beta? Minutes seem to last only 55 seconds on a certain troublesome SL-HFR70...

Franny Wentzel
Wednesday 2nd April 2003
12:15 am U.K.

franny_wentzel@yahoo.idontlikespam.co.uk

Boby...

eeeegah!- _@_OO-------oo http://www8.ocn.ne.jp/~bcc100/bp05/bp05.html

EDC-50 ED-Beta cam fanpage

Brenda Ann
Tuesday 1st April 2003
11:15 pm U.K.

brendad@shinbiro.com

Madness..

You ever get the chance to look for those old Dr. D transcriptions? :)

Madness
Tuesday 1st April 2003
10:49 pm U.K.

madness@godonlyknows.com

I had an interesting question: What's the story w/ Magnetic Video? Was is like one of the earliest releasers of prerecorded tapes? I came across a garage sale yesterday and the guy a box of prerecorded betas for 50¢ each. Most of them are MV's and the cases have copyright dates on them from about 1977-81. But yet, I played a few of them today and they're still in very good shape for tapes that old! Mono soundtracks, but still.

Charles Joly
Tuesday 1st April 2003
10:47 pm U.K.

charjol@hotmail.com

Gareth...

I guess you *might* be able to adjust the ACE w/o an oscilloscope and a reference tape, but that's a tough job.

The head can be tilted on three angles and is a PITA to adjust once it got worn.

If you ever manage to get a correct picture you'll probably need to adjust the rest of the tape path and in the end you could easily go crazy trying to get everything aligned together.

No matter what, it'll be quite longer to achieve the final results without the right tools, which just increases the chances of an accident like a slipping screwdriver hitting the video heads.

Boby
Tuesday 1st April 2003
7:43 pm U.K.

bobymc@hotmail.com

http://www8.ocn.ne.jp/~bcc100/just for fun_____________________________________

Hi....... i got a dead switcher' anybody can help?, it wont detect signal presence,its digital.

thank you very much

John Glendinning
Tuesday 1st April 2003
2:31 pm U.K.

j.glendinning@ed.ac.uk

For sale 5x2packs of Sony 2L-750BT Betamax tapes unopened £3 per pack + postage1x Maxell L500 beta tape unopened £1 + postage For people looking for high quality betamax tapes we also have 20xMaxell B20 betacam tapes will work with betamax and give 2 hours recording £40 + postage and 30x Maxell B10 betacam tapes ( 1 hour recording ) £40 + postage all boxed and unused will only sell in above lots

Jesse Alonzo
Tuesday 1st April 2003
12:57 pm U.K.

webmaster@wards.com

well the onlv JVCique deck I would be tempted to buy is that $900+ "DIGITAL VHS - HIGHLY SUPERIOR PICTURE! DIGITAL RECORDINGS ON VHS TAPE!!" digital VeHoS deck I see at Crap Buy. I hate it, it's ugly, but I'd like to see just how "good" digital VeHoS recordings are.

steve rowley
Tuesday 1st April 2003
7:50 am U.K.

steve@srowley.fsbusiness.co.uk

Wanted:

Service and user manuals for C30 and C20.

New or known VGC ACE unit for C9.

Franny Wentzel
Tuesday 1st April 2003
6:20 am U.K.

franny_wentzel@yahoo.idontlikespam.co.uk

I suppose now is not the time to note that JVC will be going out of the analog consumer VCR business due to lacklustre sales by the end of this year....

Brenda Ann
Tuesday 1st April 2003
5:01 am U.K.

brendad@shinbiro.com

Happy All F°°ls Day, everyone. You'd ßeta be careful out there. :)

Olive Thomas
Tuesday 1st April 2003
3:12 am U.K.

olive_e_thomas@yah¿¿.n¿spam.c¿m

Sony made a revision to the loading system in models past the SL-HF 450 that seem to be a constant source of problems. On older models like the SL-HF 300 loading motor drove a toothed band that was kept in tension with a tension gear on a plastic bar. On the SL-HF 450 and later models the tension bar was eliminitated in favor of holding the geared band tightly against both ends of the belt train (the gear on the loading carraige mechs and the gear of the loading motor system). Over time this doesn't seem to have been as reliable as holding the belt in tension. In the end Sony went for installing a separate motor in the loading carraige and using the geared belt to let the capstan run the reel drive.

Another common loading drive problem is when one of the gears within the loading motor drive train splits and can no longer withstand any load applied to it. PALsite has a repair guide section that covers this in depth. If you have a second loading motor/gear train assembly floating around it's an easy enough fix.

Jesse
Tuesday 1st April 2003
1:02 am U.K.

newspaperman5000@hotmail.spamstop.com

Has anyone ever dealt with Beta front-loading problems? I can't seem to get my SL-HFR70 to even accept a tape. Many thanks in advance on your comments.

Sean Meskill
Tuesday 1st April 2003
12:13 am U.K.

smeskill@attbi.comebackformore

TDK makes nice tapes. I picked up some cheap the other day, EHG I believe. It either in a bundle or in library cases, and, as nice as library cases are, they don't fit my many video holders so I got the ones in slipcases instead.

Bill Stronach
Monday 31st March 2003
11:46 pm U.K.

caol@btinternet.com

Thanks to both Steve and Sean. Having recently bought a DVD recorder, I'm in the process of transferring Beta, standard VHS and S-VHS - mainly jazz from the 8o's into the mid-90's - on to DVD-R, getting excellent results with mail-order unbranded discs at about 85p each! Yes, at least subjectively the Beta tapes have in the main survived considerably better than the VHS. It's just that with lots of relatively short segments I value the non-linear access and indexing facilities of DVD-R.

This is generating a substantial ammount of blank tape in all formats (I use a bulk eraser after finishing with a tape) so I will be able to experiment with just about every combination. Steve, I do in fact have some TDK EHG which I hope to liberate and load into Beta shells. I'll keep you posted.

previous new post   refresh  next