Featured models

Browse by date
β J F M A M J J A S O N D
1999                        
2000                        
2001                        
2002                        
2003                        
2004                        
2005                        
2006                        
2007                        
2008                        
2009                        
2010                        
2011                        
2012                        
2013                        
2014                        
2015                        
2016                        
2017      

Chat Page News
Friday 24th March 2017

Please bookmark http://chat.palsite.com/chat_page.py as the new URL.

previous new post   refresh  next
Salah
Friday 10th March 2006
10:03 pm U.K.

salahudeen52@yahoo.com

I have a Beta SL-200ME. It wasn't loading the tape,so I've replaced the loading belt.Now loading/unloading and FF/REW are OK but the machine doesn't playback.I think the mechanism needs to be acjusted.Can anyone give advice in the matter or kindly guid me to find any information about mechanism adjusting of this machine? Thanks

Olive E Thomas
Friday 10th March 2006
5:24 am U.K.

olive_e_thomas@yah.cm

Betamax starter collection...

http://cgi1.ebay.com/ws/eBayISAPI.dll?ViewItem&item=5878160861

You get a BMC-550 camcorder, SL-HF 360 some movies and a rewinder.

Olive E Thomas
Wednesday 8th March 2006
3:03 am U.K.

olive_e_thomas@yah.cm

To Adaltman: At least I can tell you it's an NTSC VCR. On the model number do you mean an EDV-7500 or are you talking about a VCR-7500 (which would make that a Sanyo and not Sony VCR - there is an important difference)?

adaltman
Tuesday 7th March 2006
1:48 pm U.K.

adaltman@verizon.net

I own a SONY Betamax 7500. I tried to use it a few weeks ago,to play some old tapes;it seemed to work fine. A week later I tried again, and it would not work. I could FF and rewind tapes, but I don't think anything at all was happening when I depressed the play button. Does this give anyone a clue as to what might be wrong? Also, where can I buy a repair kit for this machine. I'll also need a repair (service) manual. Your help would be very much appreciated. I don't know if this machine is in PAL or NTSC format; I live in New York.

Olive E Thomas
Tuesday 7th March 2006
2:22 am U.K.

olive_e_thomas@yah.cm

Might not be the capstan motor. More likely it's something on the board....

AMMor
Monday 6th March 2006
9:13 pm U.K.

gmorales10@houston.rr.com

I would like to ask for your help concerning a Betamax SL HF 870D. I'm looking for a capstan motor and pinch roll. Both the forward and rewind actions are working, but when I press play the capstan doesn't move. When I try to manually move the capstan, the sensor registers signals and though the play works; the motor doesn't.

David Hadaway
Monday 6th March 2006
5:28 pm U.K.

dhad00@nospamyah00.com

I'm selling a couple items on eBay: a case of 20 new Scotch PB20 betacam oxide tapes, = L500. Also a pair of Scotch Beta head cleaners. I have multiples, so they'll go until they're gone./

David Hadaway
Sunday 5th March 2006
5:14 pm U.K.

dhad00@nospamyah00.com

I have a bunch of hard beta cases, rigid clamshell type, gray, 6-3/4 x 4-1/2 x 1-1/8" (ah, that english system). Free for the shipping. I'm in New Hampshire USA

Paul
Sunday 5th March 2006
10:07 am U.K.

forlino@comcast.net

Thanks, Olive, for your helpful message on March 3 regarding my question about the 450!

Paul

sarah lincoln
Saturday 4th March 2006
11:54 am U.K.

sarahlincoln1@hotmail.co.uk

HI THERE DOES ANYBODY OUR THERE HAVE A SONY C9 INSTRUCTION MANUAL FOR SALE THANKS

MITCH
Saturday 4th March 2006
12:40 am U.K.

mitchdepp@hotmail.com

Help Sony slf1ub ttf1ub PAL.Automatic cut out after about 3 seconds of any function even though picture is perfect.It has a dodgy conecting lead (tuner to recorder) but i dont think thats the problem.Any ideas?

Olive E Thomas
Friday 3rd March 2006
7:13 pm U.K.

olive_e_thomas@yah.cm

Did you check to see if the cassette you were trying to record with still had it's record tab still in place? If the record tab is broken off, Sony decks will spit the tape back out if you try to record on it as a safety feature.

If the tape did have it's record tab still in place it could be that the leaf spring for the dectector is bent or broken. Not a hard fix but if you don't want the deck I could use it.

william L. Zabriskie
Friday 3rd March 2006
4:53 pm U.K.

wzabriskie@yahoo.com

I am giving away a model SF-HF400 Betamax. It is in the original box with packaging. The last time I tried to record, the drive would kick the cassette out, so we have a definite problem. If you want it you will have to pay for shippiing from Milwaukee, WI. I'm guessing that will run about $25. Otherwise this beauty will end up in a landfill.

Olive E Thomas
Friday 3rd March 2006
2:09 pm U.K.

olive_e_thomas@yah.cm

To Paul. There's a tracking control in the flipdown panel. Press both the "-" & "+" tracking buttons simultaniously to get the default center tracking. Then adjust up or down accordingly.

Slo-mo and frame advance features only work on tapes recorded in the B-III speed and will not work on B-II or B-I speed tapes. That was an intentional design decision on Sony's part

Paul
Friday 3rd March 2006
5:23 am U.K.

forlino@comcast.net

How does one adjust the tracking or sharpness on the SL-HF450? I also can't figure out how to get the slo-mo or frame-advance to work! I'm intimately familiar with the SL-HF750. One of my 750's needs a new speed control motor, but I can't find one. Does anyone know where I can get one? Thanks...

---- Paul (forlino@comcast.net) - 3/2/06

Dave
Friday 3rd March 2006
2:11 am U.K.

Betamax@rogers.com

To the above person get on EBAY and find a working betamax also either a dvd writer on your computer or a DVD recorder deck

WR Purgason
Thursday 2nd March 2006
4:41 pm U.K.

the76group@carolina.rr.com

I have 30 old sony beta movies that needs to be converted to DVD's. Who can help me with this problem. Thanks WR 3-2-06

Motty
Thursday 2nd March 2006
12:51 pm U.K.

leah38@bezeqint.net

For Sale : PAL Betamax Sony SL-P300 Video Cassette Player. Mechanically excellent working condition. Picture is snowy. Needs a technician to sort out the picture problem.

Olive E Thomas
Thursday 2nd March 2006
1:50 am U.K.

olive_e_thomas@yah.cm

The was no European release of the ED Beta format. Try Sony service. You might get lucky.

Steve Edwards
Wednesday 1st March 2006
8:02 pm U.K.

tennsurfr@aol.com

I own a ED Betamax ED7500 (US version) that has a cracked front bezel. Does anyone have a parts machine of this type? I bleieve the European model is ED7300.Steve Edwards http://www.tennsurfr@aol.com 615-477-2121

previous new post   refresh  next