Featured models

Browse by date
β J F M A M J J A S O N D
1999                        
2000                        
2001                        
2002                        
2003                        
2004                        
2005                        
2006                        
2007                        
2008                        
2009                        
2010                        
2011                        
2012                        
2013                        
2014                        
2015                        
2016                        
2017      

Chat Page News
Sunday 26th March 2017

Please bookmark http://chat.palsite.com/chat_page.py as the new URL.

previous new post   refresh  next
HAROLD KOSTER
Thursday 10th May 2007
2:06 pm U.K.

hkoster@onetel.com

I'm still looking for a perfect Sony 950 recorder. I will not tolerate 'cowboys, giving exciting descriptions that mean absolutely nothing. I will only speak to sellers who are prepared to welcome me to view their unit and then negotiate a price that is acceptable to both parties.

HAROLD KOSTER
Thursday 10th May 2007
1:58 pm U.K.

hkoster@onetel.com

I am absolutely delighted that we are once again 'on air'. Please make sure that the horrific and moronic so called members are are kept away.

Olive E Thomas
Thursday 10th May 2007
11:03 am U.K.

┐live_e_th┐mas@yah┐┐.c┐m

Welcome back PAL chatpage! We'd been worried about you...

Ron Humphris
Tuesday 1st May 2007
2:32 am U.K.

www.ronhump@tpg.com.au

Hi all,

just wondering if anyone in Betaland has a user manual or service manual for a Sony SL-800ME or for a Sony SLO-1700 ?

If I could borrow any of the above for photo copying that would be great - in return I can send a photocopy of maybe the manual you require [as of beta I have many!]

Any leads to finding these manuals would be appreciated - thanks

regards

Ron

Boby
Saturday 10th March 2007
3:22 am U.K.

bobymc@howtomail.com

Y' welkommen,I got a plenty of HF950 parts to sell...just if anyone interested in...Ah yes....a plenty sealed in aboxTDK japanese tapes too...

flyerman
Tuesday 6th March 2007
4:07 pm U.K.

gehammack@yahoo.com

Boby, Thanks alot I've got a number of sources here in the U.S. Greg

Boby
Tuesday 6th March 2007
9:42 am U.K.

Bobymc@homymail.com

A WIDE RANGE OF S T K POWER MODULE IS AVAILABLE IN MY COUNTRY.this could be a help but not all types are available......

flyerman
Monday 5th March 2007
5:13 pm U.K.

gehammack@yahoo.com

betaman, Thanks alot, sometimes I hate being right, but that's the wonderful world of electronics!I funny though I have SL-Hf500 that I've had for about 5yrs or more and use it constantly for tape and thru sourcing and its been solid as a rock, so I should probably look for it to go too. Of course I know electronics live better being used and not just setting. Thanks again!! greg

Charlie
Monday 5th March 2007
4:48 pm U.K.

betaman50@yahoo.com

Flyerman, You hit the nail right on the head! Replace the STk5441 voltage regulator in the power supply and your functions will all be restored. Plan on keeping these on hand because of most Sony betas 20 plus age they're starting to fail. About a month ago I had to replace one in my SL-HF-900. Hope this helps you out!Charlie

flyerman
Monday 5th March 2007
4:42 pm U.K.

gehammack@yahoo.com

To all, I'm new to your group, but not to betamax. I own 4 at this time and I am having a problem with a USA version SL-HFT7. I bought this on ebay and checked it out and it worked fine at start. I went to install in my system and went to play a tape and it loaded the tape, threaded up and died. The clock is still working and you can set the time, but no other functions work. It will not power up, no other functions. I checked the power supplies 5volt constant and switched are there I'm not sure about 12volt. I do not have a manual as yet but was wondering if any of you have come acrossed this. I know that it has a SKT type power regulator and possibly it just died? I've been an electronics tech for over 30yrs , so I'm not just and tinkerer, so help please!!! Also I had to change my email to my non-bussiness account, so I resent this!

Lawrence Matthews
Monday 5th March 2007
12:03 am U.K.

lawrence.matthews@uwe.ac.uk

Just to add to my previous post: I'm in Bristol in the UK.

Lawrence Matthews
Sunday 4th March 2007
11:46 pm U.K.

lawrence.matthews@uwe.ac.uk

I have a fully-working C6UB Mark II Beta which takes pride of place in my bedroom, but it's a bit bulky and hell to try and move when I need to. Would anybody with a smaller frontloader consider a trade?

Boby
Sunday 4th March 2007
3:22 pm U.K.

Bobymc@hornymail.com

I'm about to put my SL-HF95D japanese BETA on Ebay wile waiting PayPal really works in my country....

David Hadaway
Sunday 4th March 2007
1:10 pm U.K.

dhad000@yahoo.com

I have a couple auctions on eBay of Jazz videos on Beta

http://cm.ebay.com/cm/ck/1065-29296-2357-0?uid=1309682&site=0&ver=LCA080805&item=150098041063&lk=URL

http://cm.ebay.com/cm/ck/1065-29296-2357-0?uid=1309682&site=0&ver=LCA080805&item=150098011247&lk=URL

Matthew
Friday 2nd March 2007
11:46 pm U.K.

dreammc@tpg.com.au

Yes for sure, see noel.It doesn't cost much to post your machine off to him for repairBROKEN PLASTIC GEARS

Cassette carriage fails to operate due to breakage of the plastic gears in the side of the mechanism. Must be replaced

Boby
Friday 2nd March 2007
11:37 pm U.K.

boby@homealone.com

Noel might be a good help in Aussie.......

Frank
Friday 2nd March 2007
1:43 pm U.K.

frankster33@hotmail.com

Hi there,

In June last year I acquired a Sony SL-F30 stereo betamax machine. This deck was running just fine until tonight, when after I ejected a tape as I would normally, it would not accept any more tapes. Pushing the tape in does not cause the loader to take over and draw the cassette the rest of the way in. Another problem is that once the power is switched on, the left hand spool rotates for a few seconds, then the "Cassette Inside" LED on the front panel lights up and starts blinking, even though there is no cassette in there.

Being in Sydney Australia, is there anywhere I could take this unit to for repair? I have a few hundred tapes I need to transfer and I can't do it now because of this problem.

Cheers,Frank

james reames
Thursday 1st March 2007
7:45 pm U.K.

jreames1@netscape.com

Hey someone, I need a schematic or service manual for my Sanyo Betamax mod.vcr 4650. I can'tget it to turn on and stay on, Help. Jim

Charlie
Thursday 1st March 2007
4:51 pm U.K.

betaman50@yahoo.com

I got my parts from Sony yesterday and last nite I modified my SL-HF-900 to record in B1s.It took me about two hours but in the end I was sucessful and am very pleased with the results. Most of the time was spent scanning the circuit boards hunting for the right position . There was quite a few jumper wires to add and even a couple to take out but the instructions were pretty clear. I recommend that you take your time and don't expect to do it in 15 minutes. The B1s picture thats produced is much better than my NEC VC-N65EU which also records in B1s. Sonys quality is shining through. I'am gonna do some more recording tonite but at this point in time I'am glad I modified the 900.Charlie

Noel Higgins
Thursday 1st March 2007
6:10 am U.K.

noelmh@nospam.tpg.com.au

To Stewart with the two C9s,

It is much easier and safer to change over the power supplies between the two C9s to get one good machine. Then you dont have tape path alignnement issues or the potential of breaking a video head whilst changing over the drum assemblies.

cheers Noel (betaheaven.com)

previous new post   refresh  next