Featured models

Browse by date
β J F M A M J J A S O N D
1999                        
2000                        
2001                        
2002                        
2003                        
2004                        
2005                        
2006                        
2007                        
2008                        
2009                        
2010                        
2011                        
2012                        
2013                        
2014                        
2015                        
2016                        
2017      

Chat Page News
Friday 24th March 2017

Please bookmark http://chat.palsite.com/chat_page.py as the new URL.

previous new post   refresh  next
NO NAME
Friday 6th June 2008
8:52 pm U.K.

....@nec.com

Here Here..Daveyrocket, I agree with you whole heartedly. Let us discuss Betamax, let us not post addresses and try to destroy people's credibility in front of the whole planet. This can be a wholesome, worthwhile forum if we just treat it with respect. I thank the eraser for removing my address and various epithets from some disgruntled Palsite watchers. This is a chance for a new start and I, for one, look forward to all the helpful and educational posts that are sure to arrive in the future. Long live the Palsite Betamax chatpage! ☺;;

NO NAME
Friday 6th June 2008
6:22 pm U.K.

....@nec.com

To kick the new era off, I offer this query:

I have a Sony SL-HF300 that has a minor problem, and I'm hopingsomeone here can help me figure out what it is. When doing recordings, itlooks like there's some interference on the very bottom of the picture. Itmoves back and forth along the bottom, and is sort of "colorful." Thisisn't easy to describe, so I'm hoping someone understands this description.It does it especially when I record BII over BIII on the same tape or viceversa. If I record on a blank portion of the tape it will usually go awayafter a second or two, but sometimes stays for the whole recording. Thisstarted to happen when I put new heads on, and I did re-align the tape pathas necessary, so I'm guessing it may have to do with some adjustment Imissed. Other than that minor problem, the VCR works excellent.If anyone can help me with this problem, I would greatly appreciate it.

ED ☺;

NO NAME
Friday 6th June 2008
5:59 pm U.K.

....@nec.com

Here Here..Daveyrocket, I agree with you whole heartedly.

Let us discuss Betamax, let us not post addresses and try to destroy people's credibility in front of the whole planet.

This can be a wholesome, worthwhile forum if we just treat it with respect.

I thank the eraser for removing my address and various epithets from some disgruntled Palsite watchers.

This is a chance for a new start and I, for one, look forward to all the helpful and educational posts that are sure to arrive in the future.

Long live the Palsite Betamax chatpage! ☺;

K .Lambert
Friday 6th June 2008
4:43 pm U.K.

kn2000@talktalk.net

Hi:If anyone is wondering why the posts have been deleted ,you can pat the idiots on the back who continue to disrupt this board.You KNOW who you are...................Kevin

david grant
Friday 6th June 2008
2:31 pm U.K.

davyrocket2@aol.co.uk

hi especially to those who created the chat page and to everyone using and who are prepared to help those whose interest is to seek advice and help one another

K .Lambert
Friday 6th June 2008
9:40 am U.K.

kn2000@talktalk.net

Mark:PLEASE cut the profanities out.It's NOT welcome here or on any other chatpage.it's against the guidlines too.If anyone else makes these pointless and pathetic, juvenile comments can all the sensible posters PLEASE IGNORE them.Making a point of highlighting the negative remarks ONLY makes things worse.Things are getting back to normal, let's do everything to help keep it that way..........................Kevin

Craig
Friday 6th June 2008
4:30 am U.K.

kreigas@hotmail.com

Oh no, here we go again, just when things seemed to be returning to normal. What is it about this hobby that seems to attract the mentally deranged?!...

Steven
Thursday 5th June 2008
5:45 pm U.K.

NoChicNshit@palsite.co.uk

125107 125095/1212530280 cache-dtc-ah11.proxy.aol.com

Jerk off you pC of sht!

NO NAME
Thursday 5th June 2008
3:04 pm U.K.

....@nec.com

I thought we agreed to remain silent about you know who? I posted a short narrative about an NEC Beta.

What is your problem, Mark?

I think you actually wish the turmoil that this site endured should return.

If you have nothing to post about Betamax, then keep your keyboard shut.

mark
Thursday 5th June 2008
2:01 pm U.K.

mark@beta.com

Above post Ed Planks drivel - Ignore please

NO NAME
Thursday 5th June 2008
11:50 am U.K.

....@nec.com

Firstly ☺;,let's talk NEC BETAS!

Up for discussion, the NEC VC-739E, is my 4-head Beta HiFi that has lots of nice features (e.g., 3 slow motion and 2x speeds). I also happen to have 3 others, two of which had the same problem as the last one I won. In other words, here is a machine that I know very well, know exactly how to fix, and even have an extra remote and manual to use with it. The machine is cosmetically excellent, so clearly there is no particular reason to believe that the machine has been dropped or been abused.

I’m sure you all will be delighted to know that within 20 minutes of opening the box, without spending another penny I had the machine working like the day it was made. It was cleaned, nicely aligned, and every function worked perfectly. The extra VC-739 remote also worked it perfectly.

Some on this site have commented that the VC-739E made by NEC is the best non-Sony Beta HiFi ever made.

Oh and by the way,I also just bought a Sony SL-HF900 for $49.99 from the Cleveland Browns football team in perfect shape along with a dozen L-750 tapes. I wonder what you all must think of the buyer who just paid more than $380 for the same machine tonight?

Betamax rocks!

Matthew Gibb
Thursday 5th June 2008
7:55 am U.K.

dreammc@tpg.com.au

Thanks K.L

The machine is in a box (ironically a Panasonic VHS/DVD recorder combo machine box) surrounded and covered in scrunched up newspaper and will be en route to Noel's place from tuesday or wednesday next week

NO NAME
Wednesday 4th June 2008
10:28 pm U.K.

...@...com

Like I already said, it's Ed the plank. Don't let his little game spoil this site.

K .Lambert
Wednesday 4th June 2008
4:40 pm U.K.

kn2000@talktalk.net

Yes very intesting post seeing is one of my older posts for this site.So who decided to repost it under a unkown identity??The mind boggles.............and it's nothing to do with you know who...........................Kevin (KL)

simon lincoln
Wednesday 4th June 2008
4:39 pm U.K.

sarahlincoln1@hotmail.co.uk

Hi there,i have a sanyo vtc 5000 but the rewind and fast forward are very poor can anyone help with a replacement idler kit. many thanks

NO NAME
Tuesday 3rd June 2008
9:58 pm U.K.

@

Hi I have been asked, via e-mail, to discuss the Sanyo logo change. Rather than answer all these e-mails, I have decided to use this forum. The change over happened in 1987.I know this because i started working at one of their factories at that time. Sanyo's first VHS trio still had the old 'three waves' logo and they were released in 1986 (UK).They then merged with another part f their empire and created the 'neptune style' N. A lot of their VHS machines went very upmarket and this was to increase their market share that had dwindled to about 5% in 1985. Sanyo were also in 1986 simultaneously in three format camps, BETA,VHS & 8mm ,together with Sony. Sanyo to some are considered 'cheap and cheerful' and this is probably due to their (successful) bargain basement stance.They have proved , however, that they can compete with the best in terms of technology and high tech developements. I have always found their products to be excellent value , excellently reliable,attractive looking ( most cases) , ergonomically sound with great performance ,especially taking the other comments mentioned into account and the customer service is pretty dam good too. The only item they produce which does'nt quite meet these standards ,picture quality wise ,( compared to the best) are their TV's. I think maybe they try to compromise and keep the price low at the expense of the WOW factor with PHILLIPS,TOSHIBA et al. You only have to look at ther Beta machines and the fact most are still going strong and if they are faulty or a bit tired are so easy to rectify.The parts to( service) are still readily available . It'll be interesting to see how their new plasma screens hold up.... K.L.☺;

K .Lambert
Tuesday 3rd June 2008
11:27 am U.K.

kn2000@talktalk.net

Hi Matthew:The problem you've experienced with your Sanyo M10 is the first time i've heard of that happening.These machines are VERY robust in that areas as well as the entire machine.The rubber components will be the only cause of grief in not regularly serviced.

The only way i could think that would happen is if someone has removed the two metal plates at the top of the mechanism.This would cause the tape loading tray to try to load at a downward angle.As the two plastic loading tray guides would pop up

I'm sure Noel can help you with that issue though.As for your Sony C6. I'd summise capacitors causing those issues.Very common on that model.Good Luck..................Kevin

Matthew Gibb
Tuesday 3rd June 2008
10:12 am U.K.

dreammc@tpg.com.au

Hello K.Lambert, noel and the rest of the gang

On sunday while cleaning up my video shed, I was using the Sanyo M10 that I bought locally in Adelaide Australia for 50 bucks and it's being playing greatly

Then I went to put an original of Rocky 4 in and while having the tape dead centre in my hands and beginning to let the machine take it, the machine grabbed it sideways, the tape got jammed so I had to get it out and unfortunately it seems as though the tape tray/path is stuck half way between down and up.

With this machine there is no lacing of the tape strip until play is pressedSo it's time to send it over to you noel because no one in Adelaide will even take them

The tray doesn't appear broken, just stuck sideways but I can hear the motor is trying to move the tray but it's jammed in between two positions

Also my beloved Sony C6 has once again started losing it's capstan lock, so the picture tracking goes in and out. Hopefully you won't need parts for the Sanyo and once I get it back then the Sony C6 will be posted over by Australia post express mail with insurance (can't afford to lose them)

After reviewing your website, I have my eyes on the SL HF150 stereo machine on your siteI might update to a stereo machine soon and start putting my most prized betamax original movies on DVD

Oh yeah I've also got two sanyo VTC 5300 's that are not rewinding or playing that you may like as parts

Cheers

stuart
Sunday 1st June 2008
7:55 pm U.K.

stu_george@hotmail.com

Badwolf, why would you want to connect a beta to a dvd PLAYER? It is impossible anyway as a DVD PLAYER has no inputs, only outputs. Do you mean a dvd recorder?

Olive E Thomas
Saturday 31st May 2008
11:18 pm U.K.

ølive_e_thømas@yahøø.com

Assuming you're trying to connect to a DVD player and not a DVD recorder you connect the audio and video outputs of the DVD player to the A/V input of the Beta VCR. Then connect the Beta VCR to the TV in similar fashion. If your TV set doesn't A/V inputs you can connect the Beta VCR's RF jack to the TV's with the appropriate cable - you'll have to connect the Antennae or Cable TV to the Beta VCR.

previous new post   refresh  next