Featured models

Browse by date
β J F M A M J J A S O N D
1999                        
2000                        
2001                        
2002                        
2003                        
2004                        
2005                        
2006                        
2007                        
2008                        
2009                        
2010                        
2011                        
2012                        
2013                        
2014                        
2015                        
2016                        
2017      

Chat Page News
Friday 24th March 2017

Please bookmark http://chat.palsite.com/chat_page.py as the new URL.

previous new post   refresh  next
Bruce DeBeck
Friday 8th May 2009
7:01 pm U.K.

debeck@telus.net

Is there a similar website that deals with NTSC Betamax machines?

Thanks.

Madbetacollector
Friday 8th May 2009
1:24 pm U.K.

Paulr_shutty@yahoo.co.uk

Stuart, 51?

I bought mine from ebay for 34, front loading system was damaged but thanks to Charles for sending me a replacement :)

*pats C9 *

Mark
Friday 8th May 2009
8:12 am U.K.

mark@betamax.com

Oh, and to answer your question, yes it is all that is wrong with my C9. Your power supply works fine but I only have play back facility of course.

Mark
Friday 8th May 2009
8:09 am U.K.

mark@betamax.com

Thanks Stuart, on the subject of repairing them I have had two repaired in the past. They did both work for a short while but didn't last, even though the guy who repaired them drilled some nice holes in the casing for extra cooling. When working the display was very dim with both of them but the tuner was fine.

Madbetacollector
Friday 8th May 2009
6:29 am U.K.

Paulr_shutty@yahoo.co.uk

Paul, I may be wrong but if the vcr has a belt for the capstan drive then perhaps it's worn?

Have you checked the pinch roller?

Paul O.
Friday 8th May 2009
12:12 am U.K.

astro_man23@yahoo.com

Hello, I stopped by this forum to get an answer to a question. Thanks to everyone who reads. I recently picked up a Sony SL-2410 for a few bucks. I plugged it in and everything works great, even the remote, except for one glaring problem. Every two or so seconds, the picture and sound distort for an instant. Then the video and audio are perfect again until the next distortion, if that's even the right word. I thought it could be the cassette, but the same thing happens with two others I tested. A local VCR guy said it wasn't the heads. Does anyone have any ideas for how to repair? Also, when I pause it when the picture messes up, the freeze frame looks perfectly clean. Thanks again and I apologize if someone already posted a similar question.

Andy W
Thursday 7th May 2009
4:54 pm U.K.

wildeysteed@aol.com

Hi, ive not been online for awhile as my connection was lost, i have just noticed some reply's to my VTC5000 problem, i mentioned when playing back a recording made on the machine the picture dropped out, by this i mean that the sound goes and the picture goes black then it reappears with sounds very briefly and repeats itself again, but it can play tapes recorded on another machine perfectly. Also i have just fitted a new idler kit which has improved the machine alot, although some tapes get chewed when tape returns into cassette but some tapes load and unload perfectly, have i done something wrong as it never did this before or has fitting the new part highlighted another problem ?, Many Thanks, Andy

stuart
Thursday 7th May 2009
4:31 pm U.K.

stuart.george1@ntlworld.com

I am not sure what exact amount was for the new dcdc, bit 20 inclusive posgate rings a bell. I was the only bidder.

stuart
Thursday 7th May 2009
4:29 pm U.K.

stuart.george1@ntlworld.com

Is it just the dcdc amiss with your c9 mark? Yes I do remember your swap offer and I will make good on it. I intend buying a couple more c9s on ebay, and am after a spares repair one or 2. Of course also should I be able to get a dcdc repaired, i will send it your way.

Mark
Thursday 7th May 2009
8:08 am U.K.

mark@betamax.com

Stuart, how much was the dc dc on ebay if you don't mind me asking? I purchased a power supply from you on ebay and gave you C9 heads and drum a while back if you remember. You said you would try and get me a converter in exchange for them if one turned up. My C9 is out of action for many years now :(

Noel Higgins
Thursday 7th May 2009
5:27 am U.K.

noelmh@nospam.tpg.com.au

Stuart,

Re the 950 question. I have not had to fix that problem but I would be looking for dirt in a gear groove, lack of lubrication (dried out grease) or failing that a damaged gear.

I have to get a few 950s ship shape soon so no doubt I will learn.

cheers Noel

stuart
Wednesday 6th May 2009
7:53 pm U.K.

stuart.george1@ntlworld.com

Mark? If you were referring to me and my c9? ? it was already working. But I do have a spare, brand new one bought on ebay last year. I am investigating getting a non working one repaired but its not easy.

Mark
Wednesday 6th May 2009
7:39 pm U.K.

mark@betamax.co.uk

Does that mean you have a spare dc dc converter?

stuart
Tuesday 5th May 2009
8:58 pm U.K.

stuart.george1@ntlworld.com

Happy days! A recent c9 purchase on ebay arrived today and what a bargain for only 51! All that was amiss was the standard split threading gear and the associated rubber belt which was slipping. Both replaced. Its hardly got a mark on it and is in full working order, good upper drum :) Sometimes you do get lucky :)

james s
Tuesday 5th May 2009
7:21 am U.K.

Pegasus352@hotmail.com

thanks Stuart, sorry, must have misread the reply the first time! That makes 128 for the genuine Sony one sound a whole lot better! Will start saving now for next month...

stuart
Monday 4th May 2009
6:00 pm U.K.

stuart.george1@ntlworld.com

JAMES S, I believe its been said before here in response to your query, the head chips are not available sepaerately now or ever before. The disk is assembled with the cips at the factory period. There is no way anyone could mount the tips on the disk correctly so this is done at the factory by precision assembly. The part no is dsr-21r for the genuine sony disk for the c9. I picked two up from a supplier in australia last year, sadly these were the last two they had. Cost about 20 each. A friend of mine had one, I still have the other.

james s
Monday 4th May 2009
8:08 am U.K.

Pegasus352@hotmail.com

Homer, thanks for the reply, can get on with ordering one now, far cheaper than ordering the heads separately, assuming I haven't misread the website and the 124 head price is in fact the whole disk assembly! Does anyone know if the head list on this site is giving the stock code for the head chips alone or the disk? Finally got the service manual but can't get the damn thing to open!

stuart
Monday 4th May 2009
8:04 am U.K.

stuart.george1@ntlworld.com

Hi, Noel, maybe you can advise on this one, one of my 950s has a juddery shake when ejectng. The drawer is fine but the actual tape holder pops up with a juddery action when empty. When a tap is inside its fine, nice and smooth. What could be the problem?

Homer
Sunday 3rd May 2009
3:01 am U.K.

doh@hotmail.com

James S, disk assemblies come complete with the heads mounted on them.

Noel Higgins
Saturday 2nd May 2009
11:57 pm U.K.

noelmh@nospam.tpg.com.au

Buster,

To check the PS001 electronic fuse just switch the machine on (that is not standby mode) and see if the voltage is the same both sides of the fuse. Worry about getting another when you prove it is faulty.

cheers Noel

previous new post   refresh  next