Featured models

Browse by date
β J F M A M J J A S O N D
1999                        
2000                        
2001                        
2002                        
2003                        
2004                        
2005                        
2006                        
2007                        
2008                        
2009                        
2010                        
2011                        
2012                        
2013                        
2014                        
2015                        
2016                        
2017      

Chat Page News
Friday 24th March 2017

Please bookmark http://chat.palsite.com/chat_page.py as the new URL.

previous new post   refresh  next
Nicola
Thursday 21st January 2010
6:27 am U.K.

nicola71@gmail.com

Hi TheBetaMaxStore! You are a very gentleman! Thank's for you help.I cleaned that microswitches but aren't dirty.I checked with small screwdriver without cassette but the sincronism is fault.The mecanism of the drum head is loading before mecanism cassette insert.I have a piece off: i don't repair.Have you a high definition photo to guide?This is the piece: http://i242.photobucket.com/albums/ff313/Nicola717171/P1010001-3.jpg

THANKS FOR YOUR INTERESTING TO MY BETAMAX!Nicola

THEBETAMAXSTORE
Wednesday 20th January 2010
2:06 pm U.K.

BETA@HORIZON.COM

Nicola:

Disregard my last post. I looked more closely at your Betamax on the Palsite and it is different from the model that I assumed yours was.

There are 2 microswitches that control the loading and unloading. One is located at the top left of the transport and the other is located just to the left of the exit guide.Try manual operating them with a small screwdriver many times with the player turned OFF, they may just be dirty and not making contact.

Hope this helps, sorry for the first post that was incorrect.

THEBETAMAXSTORE
Tuesday 19th January 2010
8:30 pm U.K.

BETA@HORIZON.COM

Nicola:

Look at the take up reel sensor. It would be located after the pinch roller. It is the last object that the tape passes by on its way to the takeup reel and has 2 pink wires going to it. It is made to rotate and is secured by a spring. The post that holds the spring has popped off. Remove any residue left from this post and secure the spring directly to the metal chassis.

There are people on this page that devote their lives to Betamax. If I have been too vague let them come in and help you. It's not a major problem, don't let anyone make it a big deal.

All the best....via con dios.

Nicola
Monday 18th January 2010
9:09 pm U.K.

nicola71@gmail.com

Hi all,I'm Nicola and I've a Betamax Sony sl-f30 with problem.I don't speak very good english but i've a video for you.Please,see here:

http://www.youtube.com/watch?v=m9P0yXdqsbc

what happening? I'd like to repair my Betamax..Thank you very very much!

Bill
Monday 18th January 2010
10:38 am U.K.

electravibe10@googlemail.com

Chris - where are you located?

Bill

blueelephantmedia@hotmail.co.uk
Sunday 17th January 2010
1:29 am U.K.

blueelenphantmedia@hotmail.co.uk

Hi, Do you have an old VTR that isn't behaving, spending alot of time getting know where trying to make it work, 10 hours later still haven't got anwhere. Well this is when I can help.We offer a service were we will take alook at your VTR, tell you what the problem is and how to fix it for free, Then if you want us to fix it we will.

We have top old school engineers that dont let screen unturned. You will get back a fully operational machine with a three month warranty, and if you want it a direct telephone support servie should you have a problem during a job so no time is lossed.

If you would like to know more or are lookin for a particular part or machine please call Blue Elephant Media and ask for Chris on 07931 902556 or emailblueelephantmedia@hotmail.co.uk

We look forward to hearing from you

Kind RegardsChris

Roy
Thursday 14th January 2010
9:10 pm U.K.

wigan77royg@yahoo.co.uk

There is now an ALLSOP3 tape cleaner on ebay for V2000 looks ok cheap too if any V2000 collector is interested. Item number: 120517508443 Does anyone here have a working remote for a VR2080 VCR for sale thanks.

Boby
Tuesday 12th January 2010
5:07 pm U.K.

bobymc@hotmail.com

I got a unit (a switch that gives wrong parameter to Stepper driver or "logic unit" as you see rusty switch will give 010101010 not 1111111 so could that be the prob). Weak H.E sensor could also be the bottleneck, it's like loosing chaching...//other problem is that the "L.U" think that there's no Tape inserted so sometimes this can cause the tape stuck in the drawer or tape is not fully winding (wrinkle tape).

I could be wrong about this....think should read the manual again.Cheers,Boby.

Noel Higgins
Tuesday 12th January 2010
12:21 pm U.K.

noelmh@nospam.tpg.com.au

Boby,

I have seen quite a few SLHF100 reel motors with one shorted out winding due to the rotating magnet of the drive wheel wearing through the insulation and rubbing adjacent winding copper together thus shorting out a turn. The boards tend to be not perfectly flat meaning one wear through coil first. Only fix is replace the motor board and pack the bearing with a small shim of nylon as suggested on palsite. The sensing for the motor drive is by hall effect sensors which drive the switching IC.

regards Noel

Boby
Sunday 10th January 2010
8:38 am U.K.

bobymc@hotmail.com

PS: if just the plastic coupler then it's very easy tho..

Boby
Sunday 10th January 2010
8:36 am U.K.

bobymc@hotmail.com

Re: weak reel-torque, yes that the problem but what's the cause?...

to Noel: is there any sensing unit inside the Stepper circuitry or any other mod that's got to do with this problem...?

Pretty interesting Thread...for me at least..

Regards,Boby.

Noel Higgins
Saturday 9th January 2010
11:24 pm U.K.

noelmh@nospam.tpg.com.au

Stuart,

Firstly - Happy New Year!

Re your 950 tape spooling problem, you might want to also check that the tape cassettes height in the carriage is not such as to supply excess tension to the spools in their case. The plastic slides of 950s can be damaged in transit which is why they have the extra three screws to be fitted when posting or moving them.

If there is friction between the spools and the cassette case then that works against the reel motors action. By manually pressing the right switches you can trick the machine into loading with no cassette and then you can also check how much rewind torque the supply wheel is producing during the unload cycle.

If the plastic slides are cracked/broken then they will need repair or replacement.

regards Noel

Milos
Friday 8th January 2010
9:36 pm U.K.

flachance@numediacanada.com

yes, sorry, it's my error. And yes, I know the difference. Thanks.

stuart
Friday 8th January 2010
7:21 pm U.K.

stuart-george@o2.co.uk

Milos - betamax or betacam? You dont know the difference? I give you a clue - cam max... see the difference?

Milos
Friday 8th January 2010
3:39 pm U.K.

flachance@numediacanada.com

Hi, I have a Betacam SP BVW-60. I cleaned up recently and now I have a message about Error-90.Does anyone know what's the problem? I can not put a tape inside the Betacam and nothing work.Many thank!

Boby
Thursday 7th January 2010
6:51 am U.K.

bobymc@hotmail.com

Stuart, try to clean the tape presence switch. It'll help most.

Cheers,Boby.

Bill
Wednesday 6th January 2010
10:18 am U.K.

electravibe10@googlemail.com

Betadude - Connectors made to the SCART standard and sometimes called "Euroconnectors" use a rectangular plug and socket containing up to 19 connectors. They have (fairly) standardised pinouts to carry composite video, S-video and RGB video plus sound. Unfortunately, as well as being sold fully wired so they can carry everything in both directions, they also come part wired in various combinations,also in only and out only. Some are switchable.

The format was a great idea, but unfortunately it wasn't well implemented, the cables are very thick and unwieldy, and many SCART plugs fall out if you breathe near them. If they get to only six or seven percent squint you can start to lose functions. You can now get high quality and even locking SCARTS but these are usually VERY expensive.

The format is European and didn't really catch on either in the US or Japan, but the Japanese had to fit it to their VHS units and to most of their TV sets for the European market, and it is used in all satellite and digital terrestrial equipment sold here. There was only ever one Sony Beta sold in Europe fitted with a SCART, the SLHF950, which roughly corresponds to your 750. I would be surprised if your machine had a SCART socket. Your TV - I don't know. ALL TVs sold in Europe have at least one SCART socket, often two or three.

It's very easy to identify. The sockets are large, roughly rectangular, dark in colour and usually mounted flush with the surface. If they aren't visible on both the Beta and your TV, then SCART will be no good for your purpose. Also I imagine that SCART leads might be more difficult for you to find than here in Europe. SCART to RCA plug cables in various combinations are readily available here, but I again I would be sceptical about your finding them in the US.

You may well have to fall back on RCA cables (we call them "phonos" here). I'd be surprised if there isn't a video socket on your TV. The convention is to use yellow for a video socket. Many early Betas had locking "BNC" sockets for video, and if yours has one - it sticks out like a TV aerial socket and has a locking collar - you might be able to get a phono to BNC adaptor, if not you would need a lead with phono on one end and BNC on the other.

Hope some of this is helpful.

Bill

stuart
Tuesday 5th January 2010
7:53 pm U.K.

stuart-george@o2.co.uk

Hi all. Wish you all a happy new year! I require opinions on a hf950 problem, the machine is not fully winding tape back into cassette after eject, but no issue with shutting down in play and record. Is it lack of reel torque or something different?

Boby
Monday 4th January 2010
8:49 pm U.K.

bobymc@hotmail.com

Happy new day dear betamax(er), found this lil information:

http://translate.google.co.id/translate?js=y&prev=_t&hl=en&ie=UTF-8&layout=1&eotf=1&u=http%3A%2F%2Fwww.volker-schauff.de%2Ftechblog%2Findex.php%3F%2Fcategories%2F12-Videokassette%2C-12-Band-Betamax&sl=de&tl=en

good for reference ain't...Cheers,Boby.

Betadude
Saturday 2nd January 2010
2:38 am U.K.

stevechicago2004@yahoo.com

Hello~ I recently bought a 1980 Sony Betamax slo-383 (USA unit (?)....I can get the audio to play great on the tv, but I have no idea how to hook the slo-383 up to a modern TV set with the RCA cables. I heard something about a "scart cable" to use to watch the slo-383 on a tv set. Is this correct? Where would I get a "scart cable" for a Betamax slo-383? I thank everyone here and I hope you can help me.

previous new post   refresh  next