Featured models

Browse by date
β J F M A M J J A S O N D
1999                        
2000                        
2001                        
2002                        
2003                        
2004                        
2005                        
2006                        
2007                        
2008                        
2009                        
2010                        
2011                        
2012                        
2013                        
2014                        
2015                        
2016                        
2017      

Chat Page News
Wednesday 29th March 2017

Please bookmark http://chat.palsite.com/chat_page.py as the new URL.

previous new post   refresh  next
Craig Felsmann
Monday 8th March 2010
2:08 am U.K.

kreigas@hotmail.com

Hi y'all, got a problem with my SL C40 accepting and ejecting tapes. Been told parts no longer available. Anyone out there able to help??Kind regards,Craig.

Noel Higgins
Sunday 7th March 2010
10:27 pm U.K.

noelmh@nospam.tpg.com.au

Kevin,

If the pdfs are not too big to email I would appreciate copies of the HF100 and 950 manuals also.

Also Kevin, if you are confident about doing drum motors now maybe you could help Ron by fixing his 950 drum motor.

regards Noel

Bill
Sunday 7th March 2010
10:03 am U.K.

electravibe10@googlemail.com

Hi Kevin,

Your trouble is you keep being too damn helpful - it gives me an inferiority complex!I would VERY much appreciate both the SLHF100 and the 950 manuals.

All the best, Bill

Sharon
Sunday 7th March 2010
6:54 am U.K.

shazzadonna@hotmail.com

Hi,

I have a betamax player and a collection of black and white musicals among other sundries to give away if anyone in adelaide sa wants to pick it up

Ronnie
Saturday 6th March 2010
1:35 pm U.K.

ronnieenglish_1990@live.co.uk

Thanks for the info, I think it would be best like you say to leave this for someone who knows what there doing. I have managed to remove the glue from the device but this did not help. Many Thanks for your advice, If anyone out there can fix my machine, please contact me, Im willing to pay the cost for labour, parts etc.

Noel Higgins
Friday 5th March 2010
11:25 pm U.K.

noelmh@nospam.tpg.com.au

Ronnie,

I can't help you directly because I am in Australia, but I can tell you what has to happen to fix the problem. The metal plate you were talking about is actually a magnet and that needs to be levered out gently away from the board using even pressure each side. Taking care not to lose any spacer washers. On the top of the drum you need to remove the white tape guide and swing back the side black guide arm ant top anti static ground connection if necessary to clear the way for the drum to come out including disconnecting the HiFi heads connector at the top.

With as much slack as you can get on the leads going into the head assembly the three screws (with washers and springs underneath) are removed freeing the drum assembly.

The whole video drum has to be carefully removed from the machine and the drum motor circuit board taken off the drum assembly and the hall effect sensor replaced and then the whole lot reassembled. The greatest risk is damage to the video head chips which are very fragile and even though generally not available any more I saw some listed for around 450 pounds UK so you don't want to break them.

I suggest you get an experienced service person to undertake this work or you might end up having to bin the machine which would be tragic.

regards Noel

Ronnie
Friday 5th March 2010
10:03 pm U.K.

ronnieenglish_1990@live.co.uk

Hi, I cant fix my machine, So if anyone out there can, Please contact me, I would like the machine to be fully serviced.

paulgoonie
Friday 5th March 2010
8:58 pm U.K.

pmillward30@tiscali.co.uk

Hi I am looking to get a Front Loading Betamax one that has a modern stylish look to it PAL machine, any ideas which model would be most recommended. Many Thanks

Ronnie
Friday 5th March 2010
5:05 pm U.K.

ronnieenglish_1990@live.co.uk

I can also provide an image, this is on the bottom of the machine:http://img717.imageshack.us/img717/6796/dsc01858k.jpgits where the glue is, if im correct.Many Thanks.

Ronnie
Thursday 4th March 2010
9:24 pm U.K.

ronnieenglish_1990@live.co.uk

Just thought I better mention the model number;, Itís a SF-HL950 PAL. Many Thanks.

Ronnie
Thursday 4th March 2010
9:12 pm U.K.

ronnieenglish_1990@live.co.uk

Hi, I have managed to find a Sony Super Betamax recorder, but the video/drum heads are not spinning. I have seen the solution on this site that states there is a blob of glue on the bottom of the drum motor, But im having some issues accessing the bottom of the drum. I have removed the bottom of the machine, which allows me to remove the locking nut on the bottom of the drum, but the steel plate covering the motors will not budge. Can anyone offer any advice, I can supply pictures if this would help. Many Thanks, Ronnie.

Stevie Wilson
Thursday 4th March 2010
4:13 pm U.K.

steviewilson@blueyonder.co.uk

Aye thanks again Kev, top man.Still struggling where to start tho!

Stevie

K.Lambert
Thursday 4th March 2010
4:06 pm U.K.

kn2000@talktalk.net

Hi Stevie:

No problem with the C7 service manual:)If anyones else wants it or the C40 ,SLHF100 or SLHF950 ( all UB) i have them on PDF.

..........Kevin

Stevie Wilson
Thursday 4th March 2010
1:41 pm U.K.

steviewilson@blueyonder.co.uk

Hi Noel thanks for your reply. I dunno about things missing as the machine was in fine working order when I got it, I put it away for a wee bit and when I went back to it thats when its not turning on again. Power is there tho as the clock works fine, just nothing else on the front panel does anything.

Stevie

Noel Higgins
Thursday 4th March 2010
12:23 pm U.K.

noelmh@nospam.tpg.com.au

Boby,

Kind comments - thanks. I don't have enough time to do as many as I would like at the moment because I am too busy with a "real" job.

Steve,

A fault that locks the C7s up is failed (collapsed) timer switches. You can tell most times because they lose their bounce. Mind you I think they still turn on from standby just no other functions. Check all the supply lines as per the manual and go from there you might have a supply rail missing.

regards Noel

Stevie Wilson
Thursday 4th March 2010
12:32 am U.K.

steviewilson@blueyonder.co.uk

I got the service manual for the Sony C7 today, where do I start looking for a solution to my power up problem? Hopefully its a non solder fault.

Stevie

dbroo
Tuesday 2nd March 2010
6:37 pm U.K.

dbroo@yahoo.com

Does anyone know when Umatic went out of production? I'm working on a graduate thesis and I can't seem to nail down the date. Thanks.

jeffoldbean
Tuesday 2nd March 2010
5:30 pm U.K.

jeff0ldbean@btinternet.com

Noel, I got me laptop charger this morning.Found that the PCB mounted IEC/DIN mains connector, had only the Live and Nuetral,connected, on the board. So I used the original lead, which I soldered to the PCB, instead of the IEC jobby.I desoldered the output cable and fit new 12V cabling to the second regulator.Refit the charger casing. Then fit it into the PSU outer casing.All seems to work Fine.Thanks again Noel , for your Expert Help.

jeffoldbean.

Stevie Wilson
Tuesday 2nd March 2010
3:15 pm U.K.

steviewilson@blueyonder.co.uk

Hello guysI cant remember if I posted for help on here before, but here is my problem.I bought a Sony C7 from Ebay a few years back, was working fine when I got it, put it away for a wee bit as I was decorating, went back to it and there is no functions. The clock lights up but nothing else is working, the on/standby button does nothing, the play, ff ,rew, eject buttons do nothing, but I can set the time on the clock. Someone I think said it may be a fuse, but Im a complete electronics newbie, with very limited soldering skills. I have 4 betamax machines and fancy learning how to sort them, got s C6 and this C7, a Sanyo 5150 (working) and a Sanyo 5500 I think it is. Also got the spec manuals from ebay for these models, but dunno where to start with the C7 !

Stevie

Boby
Monday 1st March 2010
6:27 pm U.K.

bobymc@hotmail.com

From what I'd learned; Noel has a knowledge/know-how and very good background on fixing/modifying BetaMach, you deserved from your talent Noel probably more if you broaden your workloads.

Regarding Ebay; it's a very interesting place if you can cope with it.For me, it's a pleasure to be here and have you mates 'round...

Regards,Boby.

previous new post   refresh  next