Featured models

Browse by date
β J F M A M J J A S O N D
1999                        
2000                        
2001                        
2002                        
2003                        
2004                        
2005                        
2006                        
2007                        
2008                        
2009                        
2010                        
2011                        
2012                        
2013                        
2014                        
2015                        
2016                        
2017      

Chat Page News
Sunday 26th March 2017

Please bookmark http://chat.palsite.com/chat_page.py as the new URL.

previous new post   refresh  next
DAVID BRUNNER
Sunday 30th March 2014
3:08 pm U.K.

DAVIDBRUNNERPICAZARRI@YAHOO.ES

Hello, If I put a Y/C inputs and outputs in Betamax video, I will win quality?

K.Lambert
Saturday 29th March 2014
11:20 am U.K.

kn2000@talktalk.net

Why just the BETAMAX chatpage is being targeted i wonder.

A pointless exercise in wasting energies.Spammers go to a site worthy of your silly, pathetic, pointless efforts.

Thanks again Martin but seeing all posts removed is getting a bit tiresome.

...............

Noel Higgins
Saturday 29th March 2014
10:22 am U.K.

noelmh@nospam.tpg.com.au

Martin,

Thanks for your continued efforts.

regards Noel

Samir
Friday 28th March 2014
8:32 am U.K.

samirshubaily@yahoo.com

Good morning.Where can I buy a Sony multi-connector?I need it to connect my old Betamax video player to the HD-VPR to capture my old home movies.Thank you.

Gabriel
Monday 24th March 2014
6:45 am U.K.

noreplythismail@gmail.com

Nice job Noel, that Sanyo 6500 looks like new!If needed, I would contact you for one of those kits.

Noel Higgins
Sunday 23rd March 2014
7:19 am U.K.

noelmh@nospam.tpg.com.au

Kevin,

No problems. I used Excel to make the new labelsChanging the colour is easy.

What is hard is getting the red line to indicate record is used in conjunction with play but most people wont be using beta machines to record these days with the move to digital channels.

cheers Noel

K.Lambert
Saturday 22nd March 2014
2:07 pm U.K.

kn2000@talktalk.net

Hi Noel:

Thanks for the heads up.I actually have a guy here in the UK who is creating something near identical but in silver for the UK models (we don't have the TV/VIDEO options just 12 tuner channels).If you ever see Sanyo's original advertising for this model they made those in silver.For some reason they went with a gold colour that deteriorates badly with age.I agree Noel, the 6500 should not be overlooked, it has a pretty special performance and features to match, unusual for Sanyo beta models at the time.I think most are put off by that membrane with the usual holes in it.Still it's nice to know some are trying to rectify that:)

Nice one................Kevin

Noel Higgins
Saturday 22nd March 2014
12:03 pm U.K.

noelmh@nospam.tpg.com.au

Hello all,

For your information I have developed a replacement front panel cover for the Sanyo VTC6500 which except for this ugly problem is otherwise a very well featured and good looking machine.

See http://www.ebay.com.au/itm/181358116971?ssPageName=STRK:MESELX:IT&_trksid=p3984.m1558.l2649

regards Noel (Betaheaven.com)

Emil Jensen
Tuesday 18th March 2014
10:01 pm U.K.

ejensen1981@gmail.com

Hi Graham

The fuses are located near the whole timer block. You should undo the top cover, and be able to locate them. I had a C7 that kept blowing that fuse, after a little while in standby. It never did it when switched on.

Graham Thomas
Tuesday 18th March 2014
5:48 pm U.K.

7777glt@gmail.com

I have a SONY CL7-E betamax video recorderbeen stored for many years......switched on ,ok for a few minutes ,then went dead.Can someone tell me were the fuse F006 is located

Noel Higgins
Tuesday 18th March 2014
3:58 am U.K.

noelmh@nospam.tpg.com.au

Hi Guys,

I have been busy for quite a while but back now to fixing a few betas.

I noticed some comments below.

I use betacam oxide (ex commercial) tapes on the SLHF950 and they work great. Stay clear of the SP metal versions though. I am not sure if they actually wear the heads more but the tape formulation is wrong for the bias settings used on domestic machines anyway.

Interesting to note comments on the plastic parts Sony have used. I have just repaired some later model SLS2000 and SLT50ME multisystem machines. One of the SLT50ME machines has the front panel just falling apart after it was sent through the post because it has become so brittle. The SLS2000s are starting to show problems with the pins that sit in the white plastic load arms of the tape tray breaking off. The plastic is moulded over metal tabs and break at the point where the tab ends. You cant pin the plastic because of the metal tabs.

Plastics becoming brittle means that all of the beta machines will eventually have issues.

Manage your tapes and machine well by keeping them in a dry and cool environment.

regards Noel (betaheaven.com) Australia

Gabriel
Monday 17th March 2014
12:48 pm U.K.

gabrigpb@hotmail.com

Emails sent to Erling.

Thanks, Gabriel :-)

Erling
Saturday 15th March 2014
6:44 am U.K.

erlingds@online.no

Hi all,

I have the Sony SL-F1 /TT -F1 combination, but unfortunately it is not possible to charge the battery (NP-1) anymore. I have tried with a new battery, but no success. It seems like the charger unit has died. Is there anyone out there who has got a working AC -F1 charger for sale? (Any charger able to load the NP-1 will do)Would be great if anyone could help.

DAVID BRUNNER
Saturday 8th March 2014
1:45 am U.K.

DAVIDBRUNNERPICAZARRI@YAHOO.ES

Ok Roderick but not appears information of RM-430 unit.Other thing, the NTSC video Sony SL-HF2000 has differents speeds Beta 1, Beta 2 and Beta 3, exist PAL videos with these caracteristics?

Roderick
Friday 7th March 2014
9:30 pm U.K.

nospam@palsite.com

David, the SLO-420 (http://www.palsite.com/slo420ovi.html) is the only Betamax machine I know that will connect to a professional editor.

DAVID BRUNNER
Friday 7th March 2014
12:29 am U.K.

DAVIDBRUNNERPICAZARRI@YAHOO.ES

I found a service manual of the editing control unit Sony RM-430 and Sony RM-430CE, in the superior part appears U-matic and Betamax, exist Betamax videos for connect to this editing control unit?http://i.ebayimg.com/00/s/MTIwMFgxNjAw/z/aD0AAMXQVERSzudZ/$_57.JPG

Marc
Thursday 6th March 2014
11:02 am U.K.

tahon.marc@telenet.be

Hi,

I am from Belgium, I have a Betamax Fischer VBS 9000, and when I will play a tape, he always stops after 2 second's, please is there sombody how can help me to solf this problem.already thanks in advance

DAVID BRUNNER
Wednesday 5th March 2014
4:49 pm U.K.

DAVIDBRUNNERPICAZARRI@YAHOO.ES

There are videos as Sony SL-C20 that load the tape in clockwise, what videos load in counterwise?

Roderick
Tuesday 4th March 2014
11:00 pm U.K.

nospam@palsite.com

David, that question doesn't make sense in any way, shape or form. Could you explain what you actually try to find out?

DAVID BRUNNER
Tuesday 4th March 2014
2:25 pm U.K.

DAVIDBRUNNERPICAZARRI@YAHOO.ES

Hello, do you know what videos load to the left and what videos play and record in different speeds?

previous new post   refresh  next