Featured models

Browse by date
β J F M A M J J A S O N D
1999                        
2000                        
2001                        
2002                        
2003                        
2004                        
2005                        
2006                        
2007                        
2008                        
2009                        
2010                        
2011                        
2012                        
2013                        
2014                        
2015                        
2016                        
2017      

Chat Page News
Friday 24th March 2017

Please bookmark http://chat.palsite.com/chat_page.py as the new URL.

previous new post   refresh  next
K Lambert
Monday 9th March 2015
2:50 pm U.K.

kn2000@talktalk.net

Hi Guys

You are so correct. I searched with Google for them both :(

David.

I did have access to a similar part that fitted real tight for those old split black gears. This one was red and made from a slightly better material and was one tooth smaller but worked well.

I don't have any at the moment.

Those tools you will need to get hold of the Sony Betamax briefcase which is full of those alignment gauges and tapes.

I have one that you do pay a pretty penny for but it does the job.

The alignment tape was very worn.

Failing that sometimes you do see the odd piece from the set appear on E-Bay.

Cheers................Kev

DAVID BRUNNER
Monday 9th March 2015
1:21 am U.K.

DAVIDBRUNNERPICAZARRI@YAHOO.ES

Is necessary copy and paste because the link option is missing

Also is possible that you can't view the page, one person from Brazil told me that he could not enter in the mediafire page

Hellwyn Ballard
Sunday 8th March 2015
11:32 pm U.K.

ibex_t@hotmail.com

Kevin - copy and paste the links into your browser's address bar and hit Return (one after the other, not both together!) - they do both work.

Roderick
Sunday 8th March 2015
10:06 pm U.K.

nospam@chatpage.co.uk

Both David's links worked for me....

K Lambert
Saturday 7th March 2015
11:42 pm U.K.

kn2000@talktalk.net

David:

The links you've provided don't work :(

DAVID BRUNNER
Saturday 7th March 2015
10:29 pm U.K.

DAVIDBRUNNERPICAZARRI@YAHOO.ES

Also I need the tools for repair Beta videos, anybody can sell me or tell me where can I buy?

Link to the image of the tools: http://www.mediafire.com/view/0kgdbx9v59s5rjr/Tools.jpg

DAVID BRUNNER
Saturday 7th March 2015
12:37 am U.K.

DAVIDBRUNNERPICAZARRI@YAHOO.ES

I have the Sony SL-C30, I need the piece 281, anybody can sell me or tell me where can I buy?

Link to the image of the pieces: http://www.mediafire.com/view/36hh1sxlsdj2y0i/Pieces.png

K Lambert
Wednesday 4th March 2015
11:55 pm U.K.

kn2000@talktalk.net

Hi Hellwyn:

The tone Hi/Lo is for the mono edge track sound NOT the Hi-Fi. It basically decreases the treble or any excessive tape hiss. Mind you, the mono head and output alignment have to be pretty much perfect for you to notice that.

That has a multiplex filter for any unwanted high frequency pilot tones such as with radio FM recordings.

.Kev

Hellwyn Ballard
Wednesday 4th March 2015
11:00 pm U.K.

ibex_t@hotmail.com

Thanks Kevin.

I'm also curious what the Tone (Hi/Low) button on the SL-HF100UB does? Is it a filter? Is it connected to Beta HiFi or for all sound? (Can't find my manual at the mo :-/ )

Fivos
Wednesday 4th March 2015
7:04 pm U.K.

fivossakellis@hotmail.com

I need a new A/C head for the SL-T30ME

K Lambert
Wednesday 4th March 2015
12:31 am U.K.

kn2000@talktalk.net

Gavin:

I personally have not come across a no power issue on a C6. A C9 and HF950 yes not a C6.

the usual issues in the PSU are caps going high esr and then causing fusible resistors and transistors to fail.

Why don't you go for a newer slimmer model?

The C6 is quite a beast.

..Kevin

gavin lowe
Tuesday 3rd March 2015
5:28 pm U.K.

gavinlowe.lowe252@gmail.com

hi there Kev, just a quick question, there is a Sony c6 up for sale on eBay, now it says does not light up just dead. could this be an internal fuse or something that may need changing.

K Lambert
Tuesday 3rd March 2015
12:39 pm U.K.

kn2000@talktalk.net

That should be belt's not bet's :)

K Lambert
Tuesday 3rd March 2015
12:38 pm U.K.

kn2000@talktalk.net

Gavin:

The Toshiba I have never seen or worked on but I do know if the control track head get's dirty or worn it stops you getting a playback picture as this affects the control track part on the tape too. It's the same for Sony's too.

Sanyo's you just get the associated picture with interference.

I would look at all the bet's on the 9300 and try to get the service manual too. They can be a great help to make sure your's is in spec.

Good luck and let us know how it goes.

.........Kev

gavin lowe
Tuesday 3rd March 2015
11:21 am U.K.

gavinlowe.lowe252@gmail.com

hi there, thanks for the reply Kevin. being a beta max enthusiast i can see where you're coming from in regards to there being better models out there. i also have a question as well. i have a Toshiba v8600 and the thing is when i hit play, there is no picture, but when i hit pause a picture shows up. the tape inside the Toshiba dosent seem to be spinning around like a tape normally does. i was just wondering what the problem was and how would i go about fixing the machine as i know as with the sanyo vtc-9300, there are better machines out there but with the love of beta max, and the memories it brings, i would like to just get them fixed, which im sure you can understand. what parts would i need if any to get the beta max going. any help would be appreciated so much. by far beta max was and is the far superior format to VHS, picture wise and recording wise, period.

K Lambert
Monday 2nd March 2015
5:00 pm U.K.

kn2000@talktalk.net

Hi Gavin:

I wouldn't have thought the tape tension was too tight unless someone had been having a fiddle with it.

Far more likely the belts have stretched and it's struggling to do anything.

Not the best beta to go for in my opinion.

Sanyo's later models from the 5400 were far better.

I have only ever worked on one 9300 and that was for a no colour issue.

It's been a while so can't remember too much about that one.

My advice would be to get a later model.I have lot's or experience with those and they are far lighter and better all around.

Hope this helps?

.....Kevin

gavin lowe
Monday 2nd March 2015
12:46 pm U.K.

gavinlowe.lowe252@gmail.com

hi there, you guys. im from Leeds and i bought a sanyo vtc-9300 beta max. the person who i bought it from said it needs the tension sorting, as the tapes are to tight. how would i go about fixing this and what would i need to do. many thanks

K Lambert
Sunday 1st March 2015
11:33 pm U.K.

kn2000@talktalk.net

Also the HF950 does hours/minutes/seconds too.

K Lambert
Sunday 1st March 2015
11:32 pm U.K.

kn2000@talktalk.net

Hellwyn:

It's to do with a pulse they lay down on the tape. No pulse no counter read out. This is for the Sony's Beta's only .

Sanyo's use a different system linked to the reel drive spool.

The Sony C9 actually uses Hours minutes and seconds. Their other Beta's is just a counter function.

Keeping the tape laced at all times is how they achieved this.

As did the later VHS models, when their real time counters were added.

.......Kevin

Hellwyn Ballard
Sunday 1st March 2015
6:33 pm U.K.

ibex_t@hotmail.com

Just curious - regarding counters on VCRs that only count the part of the tape that's been recorded on - how do they know which bits are blank? Fair enough for playback they can tell if a signal's there or not, but during FF or REW are they still 'reading' the tape for signal?

previous new post   refresh  next